Common Ohio Inaccessible (Affects all locations)

Incident Report for Alene Candles IT

Resolved

Issue is now resolved.
Posted Apr 21, 2023 - 10:22 EDT

Update

Issue identified and corrected. Testing and verification. in progress
Posted Apr 21, 2023 - 10:20 EDT

Investigating

We are currently investigating this issue.
Posted Apr 21, 2023 - 09:42 EDT