Print Server Performance Degradation - ACL (INC128

Incident Report for Alene Candles IT

Postmortem

Symptoms – ACL networked printers were unable to print jobs sent to them. ACL network printers were showing ‘offline’. Users are unable to print from IFS to ACL network printers.

Observations - Several users reported the inability to print to network printers. Several minutes later our alerting system triggered the outage for the IFS agent services. Investigated the PRINT server and detected that it was crashing continuously. Crashes were linked to print jobs being sent to the server.

Resolution – We updated the Windows Server with a HotFix from Microsoft that fixed the bad update that was installed on the server. After the patch, we re-added the server to the domain and enabled the trust relationship to the server. Lastly, we rolled back a Java update to match the IFS print agent configurations.

Root Cause Analysis – The cause of this issue was a bad patch that was installed on the server from Microsoft. It caused “Blue Screen” crashes each time a print was sent to the server. This is a known issue with this patch that Microsoft apologized for. We installed the latest HotFix from Microsoft that fixed this patch. This caused the server to fall off the domain. We were able to restore the domain credentials on the server and get the printer services running again.

Posted Apr 12, 2021 - 16:20 EDT

Resolved

This incident has been resolved.
Posted Apr 12, 2021 - 16:18 EDT

Monitoring

A fix has been implemented and we are monitoring the results. All systems should now be operational.
Posted Apr 12, 2021 - 16:08 EDT

Investigating

We are continuing to investigate the issues causing this server to restart periodically. We will issue another update once we have more information.
Posted Apr 12, 2021 - 11:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2021 - 09:59 EDT

Investigating

We are continuing to investigate the issues causing this server to restart periodically. We will issue another update once we have more information.
Posted Apr 12, 2021 - 09:26 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2021 - 09:09 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 12, 2021 - 08:58 EDT

Investigating

We are currently investigating this issue.
Posted Apr 12, 2021 - 08:27 EDT
This incident affected: Network Systems (ACDC (Bedford) Data Center, ACL (Scarborough) Plant).